Cloud Printing Failure
Incident Report for Bambu Lab
Resolved
This incident has been resolved.
Posted Aug 15, 2023 - 11:53 UTC
Investigating
From 2023/08/15 10:03 to 11:10, and 12:11 to 12:23 UTC, due to abnormal network traffic, some users are experiencing login and cloud printing issues.
Posted Aug 15, 2023 - 11:53 UTC