User Login Fault
Incident Report for Bambu Lab
Resolved
This incident has been resolved.
Posted Jan 16, 2024 - 05:57 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 16, 2024 - 05:48 UTC
Identified
A subset of users are experiencing difficulties logging into their Bambu accounts due to a fault in the login module
Posted Jan 16, 2024 - 05:46 UTC
Investigating
We are currently investigating this issue.
Posted Jan 16, 2024 - 05:41 UTC
This incident affected: Bambu Accounts.