Network Outage

Incident Report for Bambu Lab

Resolved

The incident has been resolved.
Posted Dec 05, 2025 - 09:47 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 05, 2025 - 09:15 UTC

Update

We are continuing to investigate this issue.
Posted Dec 05, 2025 - 09:09 UTC

Investigating

Cloud services are experiencing access issues due to a Cloudflare outage. Details info: https://www.cloudflarestatus.com/incidents/lfrm31y6sw9q
Posted Dec 05, 2025 - 08:59 UTC
This incident affected: Printer Services (Binding, Cloud printing, Remote controlling, Live view) and Official Website, Community Forum, Bambu Accounts, Online Stores, MakerWorld.