The incident is now fully resolved. We will publish a detailed post-mortem later this week. Thank you for your patience.
Posted Jul 21, 2026 - 02:58 UTC
Monitoring
As of 18:30 UTC, our MQTT service has fully recovered. Print job initiation is now operating normally. We apologize for the disruption this caused to your printing experience. We will share more details about this incident later this week.
Posted Jul 20, 2026 - 19:26 UTC
Update
The configuration rollback is complete, and printing has been gradually recovering since 18:05 UTC. We have also identified a server with network connectivity issues and are replacing it to ensure full service stability. We're continuing to monitor closely.
Posted Jul 20, 2026 - 18:25 UTC
Identified
We have identified the root cause of this issue and are currently rolling back the related configuration to restore service.
Posted Jul 20, 2026 - 17:28 UTC
Investigating
This issue has recurred after previously being resolved. We are aware some users are again unable to start print jobs due to an issue with our MQTT service. Our team is actively investigating.
Posted Jul 20, 2026 - 17:27 UTC
This incident affected: Printer Services (Cloud printing).