Some of our store sites are currently experiencing issues

Incident Report for Bambu Lab

Resolved

This incident has been resolved.
Posted Aug 21, 2026 - 01:02 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 20, 2026 - 17:13 UTC

Identified

GCP has implemented mitigation measures and the issue is being mitigated. We are continuing to monitor the service status to ensure full recovery.
Posted Aug 20, 2026 - 17:07 UTC

Investigating

Due to a Google Cloud Platform (GCP) network anomaly, you may experience slow responses, loading failures, or intermittent disruptions when accessing some sites/services. If you encounter any of these issues, we recommend refreshing the page or retrying after a moment. If access still fails after retrying, please be patient — we are working actively to resolve it.

Incident details: https://status.cloud.google.com/incidents/utF3FMFdQfwBzJcGG6vf
Posted Aug 20, 2026 - 16:16 UTC
This incident affected: Store Services.