MakerWorld is currently experiencing a massive of traffic and is under investigation.
Incident Report for Bambu Lab
Resolved
This incident has been resolved.
Posted Sep 22, 2023 - 07:30 UTC
Investigating
We are currently investigating this issue.
Posted Sep 22, 2023 - 05:34 UTC
This incident affected: MakerWorld.