Cloud Print Service Outage

Incident Report for Bambu Lab

Postmortem

Following a joint investigation with our cloud provider, AWS, we have confirmed the root cause was network instability from the carrier, Cogent. This instability caused access requests routed through the Cogent network to experience timeouts and packet loss.

This is the same issue detailed in our another incident report: https://status.bambulab.com/incidents/s6wds2nqyght

Posted Oct 03, 2025 - 07:39 UTC

Resolved

This incident has been resolved.
Posted Sep 25, 2025 - 01:35 UTC

Monitoring

A fix has been implemented. Currently monitoring the service.
Posted Sep 24, 2025 - 12:18 UTC

Identified

A network abnormality has been identified in some regions. Our team is continuing to investigate and work towards a quick resolution.
Posted Sep 24, 2025 - 11:44 UTC

Investigating

We are currently investigating this issue.
Posted Sep 24, 2025 - 11:28 UTC
This incident affected: Printer Services (Cloud printing).