Since 09:15 (UTC), the ISP network issues in the affected regions have significantly recovered. We are now seeing success rates and latency for cloud service access in those regions return to normal levels.
Posted Jul 02, 2026 - 09:56 UTC
Investigating
We have observed a network disruption affecting several Internet Service Providers (ISPs) in parts of Europe. As a result, some users may experience the following when accessing our cloud services: - Slow page loads, timeouts, or intermittent connectivity; - Increased API latency or connection errors; - Failures when signing in, syncing, or uploading/downloading data. Initial investigation indicates the issue originates from upstream ISP networks and is not caused by an outage of our cloud services. Users in unaffected regions and on other ISPs are able to access the service normally.
Posted Jul 02, 2026 - 08:25 UTC
This incident affected: Printer Services (Cloud printing).