Partial Connectivity Issues for Users in Some Regions

Incident Report for Bambu Lab

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 01:17 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2025 - 16:13 UTC

Identified

We have implemented temporary measures, and cloud services are now gradually recovering. We are currently monitoring the results.
Posted Nov 18, 2025 - 14:25 UTC

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 12:06 UTC

Investigating

We are investigating access issues for some users due to a Cloudflare network problem. Outage Details: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 12:01 UTC
This incident affected: Printer Services (Binding, Cloud printing, Remote controlling, Live view) and Official Website, Community Forum, Bambu Accounts, Online Stores, MakerWorld.