The stores in Japan and Europe are unable to login and checkout

Incident Report for Bambu Lab

Resolved

This incident has been resolved.
Posted May 16, 2025 - 06:53 UTC

Identified

Because of a Shopify emerging incident, The stores below are unable to login and checkout:
1. eu.store.bambulab.com
2. jp.store.bambulab.com
Posted May 16, 2025 - 06:04 UTC
This incident affected: Online Stores.